White spots or strange lights with High Setting

The Twilight Render Team shares tips, ideas, helpful hints, and more on using Twilight Render
Post Reply
Fletch
Posts: 10543
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 7-2018
Contact:

White spots or strange lights with High Setting

Post by Fletch » Tue Sep 12, 2017 8:49 pm

Sometimes when you render with Easy 06 High or Easy 07 High+ strange lights or odd spot lights or white spots appear in the image. This is due to low caustics settings.

If you are a Twilight Render V2 Pro user, you can easily edit the setting to create a version with Caustics disabled.
  1. Highlight/select the "High" easy render setting
  2. Choose to edit the setting with the edit button
  3. Find the Caustics value and set to "0" by clicking the red word "Value" and then unchecking the "true" box.
  4. Choose to "Save as" and place in this location giving it a clear name:
    Windows: C:\ProgramData\TwilightV2\RenderSettings
    OSX: "~Library > Application Support > TwilightV2 > Render Settings"
  5. Then to render with the updated render setting press the "Refresh" button in the render settings pull-down menu
  6. go to the "Custom" settings to choose the updated setting as you named it.
Attachments
COMPARE.jpg
COMPARE.jpg (748.88 KiB) Viewed 1949 times
STEPS.png
STEPS.png (304.31 KiB) Viewed 1949 times

JPost
Posts: 4
Joined: Wed Apr 25, 2018 7:51 pm
OS: Windows
SketchUp: Pro 2018

Re: White spots or strange lights with High Setting

Post by JPost » Sat Apr 28, 2018 7:01 pm

Thank you so much for that information!
I´ve tried so many ways to get rid of those spots... I have tried different light settings and so on. And finally i know how to do it. Thank you! :)

rritch
Posts: 3
Joined: Wed Nov 14, 2018 11:48 am

Re: White spots or strange lights with High Setting

Post by rritch » Wed Nov 14, 2018 12:09 pm

Is there a way to disable caustics in the hobby version?

Chris
Posts: 4962
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: White spots or strange lights with High Setting

Post by Chris » Wed Nov 14, 2018 3:39 pm

You can follow the steps above to disable caustics but you will have to manually edit the render settings file in a text editor. You should be able to find the render settings at "~Library > Application Support > TwilightV2 > Render Settings"

pbacot
Posts: 241
Joined: Wed Oct 03, 2012 2:27 am
OS: Mac OSX 10.8.5
SketchUp: 2015 M1

Re: White spots or strange lights with High Setting

Post by pbacot » Fri Jan 04, 2019 6:37 am

Just came across this problem (again), and just browsed this topic by accident. Thanks!

srki12345
Posts: 1
Joined: Tue Mar 12, 2019 1:30 am

Re: White spots or strange lights with High Setting

Post by srki12345 » Tue Mar 12, 2019 1:38 am

I noticed this also when rendering interiors.
However, disabling sun in environment settings and adding spherical sky as the main light source did the trick for me.
Artificial lighting seem not to have problem with these spots. Only sun light does.

Bartas
Posts: 1
Joined: Wed Apr 10, 2019 9:16 am

Re: White spots or strange lights with High Setting

Post by Bartas » Thu Apr 11, 2019 2:55 pm

Can you get the proper lighting effect that was though? I've noticed this issue too and it would be nice to get rid of those spots.

Fletch
Posts: 10543
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 7-2018
Contact:

Re: White spots or strange lights with High Setting

Post by Fletch » Thu Apr 11, 2019 7:16 pm

Use any setting without the + sign, or you can manually edit the settings if you are a hobby user to disable the caustics.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests