installation issues with 32 bit and 64 bit Mac

Questions, bugs, help for Twilight Render V2 Hobby and Professional
Post Reply
Dudgeman
Posts: 3
Joined: Sun Aug 04, 2019 12:45 pm

installation issues with 32 bit and 64 bit Mac

Post by Dudgeman » Sun Aug 04, 2019 1:08 pm

Hi,
I have used Sketch up for years and came across Twilight recently. I have not been into rendering but now have a real need for it, Home plans and new kitchen layout etc.. Twilight was a recommendation. So issues. I have a 2010 Mac mini running 10.8.5 9 (Mountain lion I think I can't upgrade any newer as I will lose the ability to run a lot of my bought applications, logic pro 8 etc..) I have intel core 2 duo which someone said only runs in 32 bit but I have been running Sketch up 2015 pro for ages, which someone else said can't be run in 32 bit only in 64....ho hum!.
So I tried the a 64bit install. I had to do it through Preferences-extension-Install extension. On start up of sketch up i get the following error message....

Error: #<LoadError: dlopen(/Users/........../Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/TwilightLib2014.bundle, 9): no suitable image found. Did find:
/Users/............./Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/TwilightLib2014.bundle: mach-o, but wrong architecture - /Users/............../Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/TwilightLib2014.bundle>
/Applications/SketchUp 2015/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
/Applications/SketchUp 2015/SketchUp.app/Contents/Frameworks/Ruby.framework/Versions/2.0/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
/users/..................../library/application support/sketchup 2015/sketchup/plugins/twilight/twilight_start.rbs:10:in `<main>'
/Users/....................../Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `eval'
/Users/...................../Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `require'
/Users/..................../Library/Application Support/SketchUp 2015/SketchUp/Plugins/Twilight/twilight_loader.rb:2:in `<top (required)>'
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `require'
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in `load'
/Users/......................../Library/Application Support/SketchUp 2015/SketchUp/Plugins/twilight.rb:11:in `register_extension'
/Users/........................./Library/Application Support/SketchUp 2015/SketchUp/Plugins/twilight.rb:11:in `<top (required)>'


I have looked on the forum, I have made sure the read/write is activated for all users in the plugin folder.Trying to download through extension manager doesn't actually do anything (maybe a mac issue) I have tried removing the 64 bit and installing the 32 bit but still get a bunch of similar error messages and it doesn't work. Interestingly in the Library-application support folder there is only a folder for Google sketch up 8 and no folder for sketch up 2015 pro (no idea why or if it is important) I have tried to place the .rkb file in the plugin folder to see if that helps but nothing seems to work. Any help would be great. Thanks.

Fletch
Posts: 11285
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2013-20
Contact:

Re: installation issues with 32 bit and 64 bit Mac

Post by Fletch » Sun Aug 04, 2019 4:28 pm

Minimum version of Mac OS supported is 10.11
Must have 64bit versions of both SU and Twilight... and a machine that supports 64bit.
Attachments
Screenshot 2019-08-04 18.22.37.png
Screenshot 2019-08-04 18.22.37.png (98.2 KiB) Viewed 2230 times

Dudgeman
Posts: 3
Joined: Sun Aug 04, 2019 12:45 pm

Re: installation issues with 32 bit and 64 bit Mac

Post by Dudgeman » Sun Aug 04, 2019 9:30 pm

Hi Thanks...I thought I had read every bit of info on this...clearly missed this bouncing between 32 bit and 64 bit and raanting at my computer...lol... So as my mac can still run 32 bit apps do I still need 10.11 to run your 32 bit app or can i run it with an older version of SU?

Cheers

Chris
Posts: 5104
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: installation issues with 32 bit and 64 bit Mac

Post by Chris » Sun Aug 04, 2019 9:43 pm

Where did you get your download? The file naming in the error log that you posted isn't typical for our distribution of Twilight Render on OSX.

Dudgeman
Posts: 3
Joined: Sun Aug 04, 2019 12:45 pm

Re: installation issues with 32 bit and 64 bit Mac

Post by Dudgeman » Mon Aug 05, 2019 12:14 am

I downloaded the 64 bit v2 from your download page and the 32bit v1 from the linked thread on the website.

Chris
Posts: 5104
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: installation issues with 32 bit and 64 bit Mac

Post by Chris » Mon Aug 05, 2019 2:44 pm

Oh, is that error message from V1 then? That would make sense.

To my knowledge SketchUp 2015 on OSX was only ever released as 64 bit.

That said, looking at an old Mac article, the Intel Core Duo is only 32 bit but the Intel Core 2 Duo is 64 bit. https://www.macobserver.com/tips/how-to ... it-64-bit/

If you do have the Intel Core 2 Duo, and you are successfully running SketchUp 2015, I'm pretty sure you are 64 bit. As Fletch indicated, though, the current version of Twilight Render only officially supports OSX 10.11 and up. Have you tried installing TWR V2.13 though? It might work. I would clean out everything related to Twilight Render that you have installed so far and try it.

If it doesn't work, take a look at the bottom of our Downloads page. There are links there to TWR V2.11. This version (if I am remembering correctly) supported 10.8 and up. So that might work for you. https://www.twilightrender.com/index.php/downloads

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 4 guests