Render will not start

Questions, bugs, help for Twilight Render V2 Hobby and Professional
Fletch
Posts: 11289
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2013-20
Contact:

Re: Render will not start

Post by Fletch » Mon Jun 01, 2020 9:27 am

:^:

sk0tty
Posts: 5
Joined: Thu Jun 04, 2020 8:12 am

Re: Render will not start

Post by sk0tty » Thu Jun 04, 2020 9:11 am

This is busting my head !
Selecting the render button now does nothing. I was rendering a few angles of my drawing, I got to 9 renders, everything was going swimmingly. I tried to do a 10th and when I pressed the render button, it did nothing.
Ive reset the pc, Ive uninstalled Twilight render and reinstalled, Ive pressed the reset buttons in the options menu and cleaned all materials, Ive also tried to render basic shapes.
THE RENDER BUTTON DOES NOTHING.

PLEASE HELP !!

Fletch
Posts: 11289
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2013-20
Contact:

Re: Render will not start

Post by Fletch » Thu Jun 04, 2020 1:45 pm

Hi Sk0tty, that is frustrating indeed. But it is also very strange.

Please be patient with me as I try to understand exactly what is wrong so that we can fix it. Please answer my questions.

Are you saying it will not render any scene at all even with a new sketchup scene and just a basic cube? Or it will not render anything when you are in a particular file?

Can you share a link to the file to download for testing purposes?
Can you make a short video demonstrating the problem (screentogif is a nice program for short demo recordings like this)

Do you remember what you changed last before you had this problem?
Did you set it to render only a particular scene, did you turn off updating geometry, etc?
Please try to show a video of what happens, and provide a test scene so that we can try to reproduce the error.
Thank you.

sk0tty
Posts: 5
Joined: Thu Jun 04, 2020 8:12 am

Re: Render will not start

Post by sk0tty » Thu Jun 04, 2020 5:11 pm

Thank you Fletch for replying and trying to help, its very much appreciated.

Ive used the screen to gif link you provided and made a video for you which can be seen below (next post)

Before it stopped working I was rendering a drawing that included light sources, I managed to render a few images with no issues but then the render window just stopped responding to the open up request.
No matter if I use another drawing with no lights or fancy materials or if its a newly drawn box in the middle of the screen, pressing RENDER does nothing. The window doesn't open up. All the other windows open, light editor, material editor, even the animation editor. And that renders. Its as though the command to open the window isn't there anymore, the button is unresponsive.
Last edited by sk0tty on Thu Jun 04, 2020 5:16 pm, edited 1 time in total.

sk0tty
Posts: 5
Joined: Thu Jun 04, 2020 8:12 am

Re: Render will not start

Post by sk0tty » Thu Jun 04, 2020 5:15 pm

TwilightProblems.gif
TwilightProblems.gif (1.09 MiB) Viewed 1015 times

Chris
Posts: 5105
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: Render will not start

Post by Chris » Thu Jun 04, 2020 6:20 pm

That looks exactly like what happens when the render is off screen. Did you reset the dialog positions, as mentioned before?
options.png
options.png (19.46 KiB) Viewed 1010 times
Click both resets, close the window, and restart SketchUp.
If that doesn't work, shut down SketchUp, find and delete the Twilight Render options file (on Windows, it's here: C:\Users\your user name\AppData\Roaming\TwilightV2\twilight_options.xml.) Then restart SketchUp.

sk0tty
Posts: 5
Joined: Thu Jun 04, 2020 8:12 am

Re: Render will not start

Post by sk0tty » Fri Jun 05, 2020 7:47 am

Thanks Chris,
Resetting the dialog positions doesn't seem to do anything to fix this.
For the best part, deleting the file twilight_options.xml and restarting Sketchup appears to be what works. I can open a drawing, click render, the render window opens and will render.
If I keep the render window open I can edit materials and set the render away again. However, if I then shut the render window and try to re-open it then I'm back to square one. I then have to close Sketchup and again delete the twilight_options.xml file.
It appears to be the case that if I don't edit any materials then the render window will open and close repeatedly.

At least I have a temporary fix.

Thanks again.

Fletch
Posts: 11289
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2013-20
Contact:

Re: Render will not start

Post by Fletch » Fri Jun 05, 2020 9:19 am

Can you show a short video of how the error occurs? (how it works, then you close the render window, make material edit, open the render window, but it is not there) No one has ever reported this before and we would like to fix the issue.

rodz56
Posts: 6
Joined: Wed May 20, 2020 6:56 am

Re: Render will not start

Post by rodz56 » Fri Jun 05, 2020 10:35 am

Hi Fletch

I did mange to get a couple of images to start rendering by re-installing all the relevant software, but as soon as I made any changes in Template Materials it refused to open again. Sounds a very similar problem to another of your forum users who has posted recently. Not sure if this gives any clues to whats going on.

rodz56
Posts: 6
Joined: Wed May 20, 2020 6:56 am

Re: Render will not start

Post by rodz56 » Fri Jun 05, 2020 11:00 am

Just to add, deleting the Options file also gets things working again for me so thanks for that help but has to be re-deleted each time.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests