Como tirar manchas pretas de materiais em vidro?

Post Reply
cscofano
Posts: 8
Joined: Fri Feb 27, 2015 10:30 am

Como tirar manchas pretas de materiais em vidro?

Post by cscofano » Wed Aug 24, 2016 2:39 pm

Bom dia!
Tenho me deparado com este problema quando
vou renderizar cenas com taças de vidro.
Configurei o material Template\Common e renderizei
no motor advanced\Alternative_AA\04d_Medium_AA4(ultra).
Como faço para apagar essas manchas pretas? Se eu criar um
material avançado (deep material) posso como evitar isso?

Good Morning!
I have encountered this problem when
i will render this scene with glass bowls.
I set the Template \ Common materials and render with
the engine Advanced \ Alternative_AA \ 04d_Medium_AA4 (ultra)
How do I delete these black stains? If I create a
Deep material, can avoid this problem?
Attachments
black stains.jpg
black stains.jpg (830.5 KiB) Viewed 3717 times

Fletch
Posts: 10730
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2018-2019
Contact:

Re: Como tirar manchas pretas de materiais em vidro?

Post by Fletch » Thu Aug 25, 2016 3:16 pm

Hello, your light object is intersecting or touching adjacent geometry. Set your light radius to be very small... around 1cm. Make sure your light object is not touching other 3D geometry in the scene.


cscofano
Posts: 8
Joined: Fri Feb 27, 2015 10:30 am

Re: Como tirar manchas pretas de materiais em vidro?

Post by cscofano » Fri Aug 26, 2016 2:00 pm

Olá, Fletch!
Obrigado pela ajuda, mas o problema ainda persiste.
Não havia interseção no objeto de luz e o raio dele
já estava com 0,005m.
Fiz um teste com a mesma cena no MLT e as manchas desapareceram.
O problema ocorreu no Advanced\ Alternative_AA\ 4d. Medium_AA4(ultra).

Acredito que, talvez, o problema seja a escolha do motor de renderização.
Ou existe alguma configuração que evita
as manchas e ainda não descobri.


Hello, Fletch!
Thanks for your help, but the problem still persists.
There wasn't intersection between the light object and
other geometry, and the radius was already 0,005 m.

I did a test with the same scene in the MLT and stains disappeared.
The problem occurred in the Advanced \ Alternative_AA \ 4d. Medium_AA4 (ultra).

I think perhaps the problem is the choice of the rendering engine.
Or is there some setting that prevents
stains and have not figured out.

Chris
Posts: 5020
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: Como tirar manchas pretas de materiais em vidro?

Post by Chris » Fri Aug 26, 2016 2:11 pm

You will need to edit your preset. Most (or all) of the biased presets (Low, Medium, High) have a maximum ray depth of 5. This means they will go through 5 surfaces. Since your glass is double sided, going through a single glass is 4 surfaces in itself. So it can't penetrate full through a second glass. You will need to find and increase the Max Raytracing Depth value, probably a value like 10 or even 20.

<Parameter Name="Max Ray Tracing Depth" Type="Integer" Value="5"/>

However, with so many surfaces, you are probably better off using the Interior / Interior + render setting.

Fletch
Posts: 10730
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2018-2019
Contact:

Re: Como tirar manchas pretas de materiais em vidro?

Post by Fletch » Fri Aug 26, 2016 10:59 pm

It looks like the light object is placed behind a surface in the light fixture. It looks like you may have a glass lens on the light fixture, and have placed your light inside of that... I would delete that surface, or change the material for it to be glass>Architectural>common at the very least. I've seen these artifacts many times, and it's always from the light intersecting geometry.
Attachments
black stains.jpg
black stains.jpg (191.93 KiB) Viewed 3687 times

cscofano
Posts: 8
Joined: Fri Feb 27, 2015 10:30 am

Re: Como tirar manchas pretas de materiais em vidro?

Post by cscofano » Wed Aug 31, 2016 1:45 pm

Muito obrigado Fletch!
Alterei o preset (Max ray tracing depth) conforme
a sua orientação e funcionou corretamente.
Gostei muito dessa solução, pois prefiro renders
biased devido a rapidez de renderização.
Até logo!

Thanks a lot, Fletch!
I changed the preset(Max ray tracing depth)
as your orientation and worked correctly.
I liked very much this solution, because i prefer
biased presets because the speed of rendering.
See you later!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest