Denoiser & Animation

For all the users of Twilight Render (V1 & V2), to ask questions and get started
Post Reply
rotom85
Posts: 6
Joined: Fri Oct 14, 2022 3:10 pm

Denoiser & Animation

Post by rotom85 » Mon Jan 23, 2023 7:10 pm

Hello,

I bought the denoiser, and I want to use it for an animation. I render in 07. Interior Animation 500. The denoise is not displayed on the image, why please?
In addition I set the maximum iteration to "5". But it stays on "500". It's way too long for me.
Is it possible to make an animation with the denoiser with a given number of iterations?

Thank you very much
Thomas R.
Capture d’écran 2023-01-23 195235.png
Capture d’écran 2023-01-23 195235.png (1.56 MiB) Viewed 413 times
Capture d’écran 2023-01-23 195313.png
Capture d’écran 2023-01-23 195313.png (1.15 MiB) Viewed 413 times

rotom85
Posts: 6
Joined: Fri Oct 14, 2022 3:10 pm

Re: Denoiser & Animation

Post by rotom85 » Wed Jan 25, 2023 2:39 am

Hello,

Well I tried again today, my computer was off, I turned it back on and now it works!
Maybe just restart sketchup.

Good for you.
Thomas

Fletch
Posts: 12532
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 2020-2022
Contact:

Re: Denoiser & Animation

Post by Fletch » Fri Jan 27, 2023 9:46 am

rotom85 wrote: Wed Jan 25, 2023 2:39 am Hello,

Well I tried again today, my computer was off, I turned it back on and now it works!
Maybe just restart sketchup.

Good for you.
Thomas
:^: Glad to hear you got it working. The old classic remedy. :clap:

JGA
Posts: 224
Joined: Fri Aug 28, 2009 12:13 pm
OS: win7 pro 64 bit
SketchUp: 2015 pro

Re: Denoiser & Animation

Post by JGA » Fri Jan 27, 2023 1:55 pm

You may have a problem using a denoiser with an animation, as each denoising each frame can add a little variation in detail between one image & the next.
This seems to be an issue with all but the very latest denoising packages. It's not related to any particular rendering package, but the third party denoising component (intel & nvidia).
Google "using a denoiser for animation" & you see the problem flagged up on many rendering platforms.
Good luck!
JGA

rotom85
Posts: 6
Joined: Fri Oct 14, 2022 3:10 pm

Re: Denoiser & Animation

Post by rotom85 » Sat Feb 04, 2023 5:38 pm

Good morning,
@JGA Yes, but apparently it's not just about the animation. I'm on a new render in 10.Interior+. The denoiser is activated and nothing happens...
I rebooted, chose the NvidiaRXT graphics card. Nothing changes. :o

Dimensions below 2133 x 1505 px , Denoise it works!
Dimensions above 2134 x 1506 px , Denoise doesn't work!

How can i make big images with the denoiser? In fact, that's why I bought it. :roll: Thanks, Thomas

Log Window :
(22:15:02: Log Started.
22:16:42: Geometry Processing Time: 10 (s)
22:16:48: Denoise Error: Initialize::CUDA Error: out of memory)


My Total Available Graphics Memory is 8Go. I've a NVIDIA GeForce RTX 2060.
Attachments
Capture d’écran 2023-02-04 183731.jpg
Capture d’écran 2023-02-04 183731.jpg (447.58 KiB) Viewed 264 times

JGA
Posts: 224
Joined: Fri Aug 28, 2009 12:13 pm
OS: win7 pro 64 bit
SketchUp: 2015 pro

Re: Denoiser & Animation

Post by JGA » Mon Feb 06, 2023 8:34 am

I think you've just hit the limit with your graphics memory capacity. I have the same issue with the two rendering packages I use with an older 6Gb Quadro card. It's a limitation of the Optix technology at the moment.
Are you able to optimise your materials any further? Perhaps hide chunks not in view, to avoid loading areas out of the active scene into memory? Swap out 3D trees not in the foreground for 2D billboards?
JGA

Chris
Posts: 5262
Joined: Sun Mar 08, 2009 3:00 am
OS: Win10
SketchUp: 2016

Re: Denoiser & Animation

Post by Chris » Mon Feb 06, 2023 2:55 pm

There is an option to limit the amount of memory used for the Denoiser. By default it is set to "No Limit" but leaves you open to the possibility of running out of memory. Setting the limit will ensure you don't run out; the trade off is the denoising process may take a little longer (but not much).

Go to Extension -> Twilight Render V2 -> Options. Click on the Options tab and look for the drop down for Denoiser Memory Limit. Probably setting it to 1GB will work for your case but if you continue to have problems, try lowering it to 512MB.

Please note that after changing the Denoiser setting it is best to restart SketchUp to make sure all settings get applied and any problems get reset.

JGA
Posts: 224
Joined: Fri Aug 28, 2009 12:13 pm
OS: win7 pro 64 bit
SketchUp: 2015 pro

Re: Denoiser & Animation

Post by JGA » Mon Feb 06, 2023 4:46 pm

Chris wrote: Mon Feb 06, 2023 2:55 pm Extension -> Twilight Render V2 -> Options.
Thanks for pointing this out.
JGA

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 3 guests