Dots on render

For all the users of Twilight Render (V1 & V2), to ask questions and get started
Post Reply
Mnvital
Posts: 17
Joined: Fri May 18, 2018 8:48 am

Dots on render

Post by Mnvital » Wed Apr 17, 2019 2:35 am

Hi folks!

I’m a beginner, so I guess it’s a very simple question, but anyway, there it goes:

When I render on low+ or medium (inclusive using AA alternatives render settings), some materials keep displaying some weird clear dots (maybe due to bump). But I really don’t understand how ca I fix that.

My system:
MacBook Pro (Retina, 15-inch, Mid 2015)
MacOS 10.14.13
Sketchup v. 19.0.684
Twilight Render v. 2.18.8 Pro

I’m using deep editor imported wood material from a Kerkythea Library.
C89EA196-F0F3-41AC-AE2C-4399C04353D5.jpeg
C89EA196-F0F3-41AC-AE2C-4399C04353D5.jpeg (55.5 KiB) Viewed 229 times
Thanks for any help!

Fletch
Posts: 10619
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 7-2018
Contact:

Re: Dots on render

Post by Fletch » Wed Apr 17, 2019 3:20 pm

Without scene for diagnostics, it's difficult to guess.

It could be the caustics, try rendering with Easy 04 or 06 (no + sign).
It could be the quality of sampling in the render setting. Try increasing quality (Easy 06 should be good) or try a different material setting/template, see below.

You could try applying the Template>Wood instead of the library material and test if that helps fix the problem. Some KT libraries are actually not well-built physically accurate materials.

However, looks like it's likely specular sampling of sky into specular of wood material and that specular sampling is bad, needs to be improved, or eliminated. Again, try the Template>Wood.

Mnvital
Posts: 17
Joined: Fri May 18, 2018 8:48 am

Re: Dots on render

Post by Mnvital » Thu Apr 18, 2019 3:29 pm

Hi,

Now I used template material with a simple bump map. It worked fine! I went further and, on bump, used a bevel behaviour. Some shapes, now, display a strange "shadow" in some rendering angles as you can see below...
strange-shadows.jpg
strange-shadows.jpg (425.84 KiB) Viewed 197 times
I'll attach my work file (this link to One Drive - https://1drv.ms/u/s!AvNEqGw4gWRd7xopQCtyC-qoTVgi)

Thanks!

Fletch
Posts: 10619
Joined: Fri Mar 20, 2009 2:41 pm
OS: PC 64bit
SketchUp: 7-2018
Contact:

Re: Dots on render

Post by Fletch » Tue Apr 23, 2019 10:09 am

Please see this video about Twilight Render bevel settings.

Make sure all faces are front face.
Make sure weld and weld angle is set properly (see video linked above)

Post Reply

Who is online

Users browsing this forum: No registered users and 4 guests